FluentPro Help Center

What do you need help with?

"Unable to establish connection to PWA with specified login" error

Symptoms

Backup/Copy, etc. process in G.A. Suite fails with an error - 

"Unable to establish connection to "PWA URL" with login username@company.com"

Cause

To perform any action G.A. Suite requires a connection to the PWA. By default, the login and password specified upon adding PWA URL to G.A. Suite, are used for connection and authorization to PWA. These credentials can be found on the Credentials Manager or Credentials page.

The above-mentioned error occurs when for some reason G.A. Suite could not connect to the PWA with the provided login and password.

Common reasons:

1. The password, specified on the Credentials Manager or Credentials page, changed.

2. The account, specified on the Credentials Manager or Credentials page, lost access to the PWA.

3. Custom type of authentication to PWA was introduced instead of common Office365 login.

4. The password, specified on the Credentials Manager or Credentials page, changed or expired due to the password expiration policy in Active Directory of the O365 tenant.

5. Temporary issues with connection to Project Online.

Please note: For copying operations, it may be required to update credentials for both Source and Target PWAs, for the reasons listed above. If you received an "Unable to establish connection to "PWA URL" with login username@company.com" error, please make sure to validate/update both Source and Target PWA credentials following the steps described below.

Solution

You can update credentials on the Credentials Manager or Credentials page. We will review the example on how to solve the issue from the credentials page, but you can use the Credentials Manager page as well. 

1. Navigate to G.A. Suite and choose the environment, for which an error "Unable to establish connection to "PWA URL" with login username@company.com" occur

2. In the opened list page click on the Credentials option: 

3. On the Credentials page click Save to validate your credentials: 

Credentials validation process will begin. 

  • If credentials are valid and G.A. Suite was able to establish a connection, the Credentials page will be closed and you will be redirected to the Home page. 
  • If the credentials are not valid and it is required to update them, you will need to provide valid credentials and click Save. 
    If your Office 365 account has multi-factor authentication enabled, please refer to this article for a detailed description of the steps you need to take. 

From now on G.A. Suite will be using the credentials provided and will be able to successfully establish a connection to the PWA.

Please note: If you have a scheduling profile set up for Copying, Documentation, Backup or Projects Publish, and specific credentials in the "Specific Credentials" option was provided, updating credentials for the PWA following the steps described above will not solve the issue, as different credentials are provided in the scheduling profile. In this case, while performing Copying, Documentation, Backup or Projects Publish operations, G.A. Suite will use the credentials specified in the "Specific Credentials" option.

In order to update the credentials for such cases, perform the following:

1. Navigate to G.A. Suite and choose the environment, for which an error "Unable to establish a connection to "PWA URL" with login username@company.com" occurs.

2. Navigate to the Schedules option and open the scheduling profile where the "Specific Credentials" option was selected and the specific credentials were provided. 

2. Provide the valid user name and password in the "Specific Credentials" option once again. 

3. Scroll down and click Save to save the profile. 

Was this article helpful?

Table of contents

    Back To Top